Service Issues in the Excelsior Springs area

Incident Report for United Fiber

Resolved

The network has recovered and stabilized.
Posted Dec 10, 2025 - 16:34 CST

Monitoring

We are currently investigating service issues within the Excelsior Springs market. Service may be degraded for some in the area. Issues started occurring at 3:20pm CST. We have identified the issue with an upstream provider. We have put in some mitigating measures to reroute traffic.
Posted Dec 10, 2025 - 15:49 CST
This incident affected: Network Services (Network Infrastructure).