Savannah Outage

Incident Report for United Fiber

Resolved

This outage is now resolved.
Posted Sep 11, 2025 - 13:11 CDT

Update

Splicers continue to bring people back up. Estimated time for full repair is extended to an hour from now.
Posted Sep 11, 2025 - 11:48 CDT

Update

The current estimated time of repair is 2 hours.
Posted Sep 11, 2025 - 09:38 CDT

Identified

We have a small outage in Savannah MO, near Chestnut Street, affecting roughly 100 customers. This outage is due to a hit pedestal. We currently have people on site working to assess the damage and resolve the issue.
Posted Sep 11, 2025 - 08:29 CDT
This incident affected: Network Services (Network Infrastructure).