Emergency repairs to the damaged fiber infrastructure have been completed, and service has been restored to customers as of 2:00 PM.
We appreciate your patience and understanding while our Field Operations team completed the necessary repairs to restore service. If you are still experiencing any issues, please reboot your equipment. If problems persist, please contact our Technical Support team for further assistance at 800.585.6454.
Posted Jul 09, 2026 - 14:18 CDT
Identified
Service Outage – Maryville, MO (Business Highway 71 Area)
Our Field Operations team is currently performing emergency repairs to damaged fiber infrastructure affecting customers in the Business Highway 71 area of Maryville, MO. Service has been temporarily interrupted while crews complete the necessary work to restore network connectivity.
* Affected Area: Business Highway 71, Maryville, MO * Outage Start: Approximately 11:19 AM * Estimated Time of Restoration (ETR): 11:39 AM
Crews are actively working to complete repairs and restore service as quickly and safely as possible. We appreciate your patience and understanding and will provide additional updates as they become available.
Posted Jul 09, 2026 - 11:55 CDT
This incident affected: Network Services (Network Infrastructure).