St. Joseph Outage

Incident Report for United Fiber

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 11:36 CDT

Investigating

We are currently investigating an outage in the St. Joseph area around Riverside, East US Hwy 169, and Deer Park. We are aware of the situation.
Posted Jul 01, 2026 - 08:26 CDT
This incident affected: TV Services (TV Service), Phone Services (Phone Services), and Network Services (Network Infrastructure).