Network outage
Incident Report for United Fiber
Resolved
The network has been stable for multiple days. We are considering this outage resolved. If you still are experiencing issues please reach out via 800-585-6454 or go https://unitedfiber.com/contact-us
Posted May 01, 2024 - 08:57 CDT
Update
While our network is functioning as expected, we believe all customers should be operating normally. If you're encountering any individual issues, please submit a ticket using the following link.
For efficient handling of your private information, please submit a ticket through our website at unitedfiber.com/contact-us. Facebook is not our preferred method of communication.
Posted Apr 29, 2024 - 18:39 CDT
Update
This outage is now resolved.
Posted Apr 28, 2024 - 15:19 CDT
Update
We are seeing issues on our Savannah Shelf currently. Out networking team is working to resolve this issue as fast as possible.
Posted Apr 28, 2024 - 14:22 CDT
Update
We are still in the process of converting our Savannah customers over to the new stack of equipment which will continue throughout the night and into tomorrow until everyone Savannah customer is moved over.
Posted Apr 24, 2024 - 21:19 CDT
Update
We've initiated the testing phase for transitioning our Savannah customers to new equipment. To ensure a seamless transition, we're starting with small groups. During this process, customers may experience a brief interruption in service. We'll provide regular updates on our progress and thank you for your patience as we work to resolve this issue
Posted Apr 24, 2024 - 13:53 CDT
Update
Due to the recent power outages in the Savannah and St. Joseph areas, we're observing an increase in customers experiencing connectivity issues. We're actively addressing this situation to restore service for as many customers as possible and exploring options to enhance conditions. Additionally, our initial plan to transition Savannah customers to new equipment in the coming days is still in place.
Posted Apr 24, 2024 - 08:47 CDT
Update
Attention Minerva TV Customers!
We have recently rebooted our Minerva TV platform to enhance its performance. Your TV should now be running smoothly. However, if you encounter any issues, please follow these steps: unplug the TV box connected to your TV, wait 30 seconds, and then plug it back into the power. This should resolve any TV issues you may be experiencing.
Posted Apr 20, 2024 - 20:20 CDT
Update
Attention Fiber Customers! Last night's preliminary maintenance went smoothly with minimal disruptions to our services, preparing us for tonight's major maintenance, where we will swap out our core router. The maintenance window is scheduled from midnight to 5 am, during which potential outages may occur. We appreciate your cooperation and understanding during this time. We apologize for any disruptions this may cause, however, we believe this is the best course of action to correct the issues some of our customers have seen over the last few days.
Posted Apr 20, 2024 - 11:48 CDT
Update
Attention all United Fiber customers we will be conducting maintenance at 12:00AM and ending at 5:00AM. There may be a potential outage from 2:00 AM to 2:30AM. We appreciate your patience and understanding at the time.
Posted Apr 19, 2024 - 23:15 CDT
Update
Our network team continues to evaluate the network and perform maintenance throughout the evening. Any potential service-effecting maintenance will be performed between midnight and 5am. Due to the nature of this event, customers are affected sporadically across the network which makes any final ETA hard to determine, however our overall outage totals continue to decline. We will keep you updated with any significant information.
Posted Apr 19, 2024 - 22:38 CDT
Update
We've recently noticed that some of our customers have accidentally hit the reset button on their routers, causing their Wi-Fi settings to revert to default. If you have hit your reset button on one of the routers shown, please follow the steps explained in the video to restore your Wi-Fi settings.
The proper way to restart your router is to unplug it from the electrical outlet for 30 seconds and then plug it back in. If you have hit the factory reset button, please watch the following video.

https://youtu.be/MFYsm3_571k
Posted Apr 19, 2024 - 18:45 CDT
Update
CEO Jim Bagley gives an update on the broadband outage. Click link to view.
https://www.youtube.com/watch?v=dYBztef6ycU/
Posted Apr 19, 2024 - 14:41 CDT
Update
We are down to a handful of customers who are still experiencing issues with their service. Our network team has been working through the night to get everyone restored as quickly as possible. We will continue to work diligently throughout the day to restore this outage. We sincerely apologize to our customers for the outage and appreciate your patience.
Posted Apr 19, 2024 - 08:20 CDT
Update
We are down to 3% of our customers experiencing issues. Our team continues the process of bringing back the remaining customers without service. Again, we sincerely apologize for the inconvenience this has caused our customers. We appreciate your patience during this time.
Posted Apr 18, 2024 - 15:30 CDT
Update
As of early this morning, we are seeing progress on customers' ability to reconnect. Our network team is currently bringing more customers back online. We believe the current process will show significant improvement throughout the day. We will keep you updated as we have more detailed information.
Posted Apr 18, 2024 - 08:51 CDT
Update
We are still working on the network and will continue to do so overnight. Short or brief network interruptions could be possible. We will continue to provide updates as we have them. Thank you for your patience during this time.
Posted Apr 17, 2024 - 22:16 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2024 - 17:29 CDT
Update
We sincerely apologize for the ongoing outage and the inconvenience this has caused our customers. Our techs continue troubleshooting our network and our customer care team is contacting customers.
If you have tried to call in and were unable to get through, our call queue is most likely full due to the influx of outbound and incoming calls. Please use this link to contact us if you haven’t already had a ticket opened. https://unitedfiber.com/contact-us We thank you for your patience as we diligently work to resolve this issue.

Thanks,
Posted Apr 17, 2024 - 15:57 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2024 - 14:45 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 21:32 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 19:23 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 18:24 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 16:58 CDT
Update
Attention all United Fiber customers!

Today at 3:30 PM, United Fiber will be conducting emergency maintenance on our equipment. We're addressing issues caused by this morning's power outage.  This maintenance is expected to last between 10-15 minutes, and your service may experience a brief interruption. We sincerely apologize for any inconvenience this may cause. We will be providing updates throughout our progress. Thank you for your patience and understanding!
Posted Apr 16, 2024 - 14:51 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 13:35 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 12:34 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 11:35 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 10:36 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 09:44 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 16, 2024 - 09:43 CDT
This incident affected: Network Services (Network Infrastructure).