Full network restoration occured at approximately 1150AM. Hands off at 12PM - all services have seen a complete recovery.
Posted Mar 14, 2025 - 15:00 CDT
Update
A majority of network traffic has been migrated to alternate links. We're seeing traffic nearing a normal load. Network Operations continues to swing over traffic in order to fully restore all service. Once completed, we'll monitor performace. We'll continue to provide updates as soon as they are availalbe.
Posted Mar 14, 2025 - 11:54 CDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 14, 2025 - 10:33 CDT
Identified
Fiber services to Excelsior Springs service area is experiencing a service degredation and/or outage at this time. Network Operations team has identified to the issue and is working on steps to mitigate the issue to fully restore service.
Posted Mar 14, 2025 - 09:09 CDT
This incident affected: Network Services (Network Infrastructure).