Giga Spire Maintenance

Scheduled for Jul 3, 00:00 CDT  -  Jul 5, 12:00 CDT

Update

Edit 2: This has been moved again to June 3-5.
Posted May 27, 2025 - 14:31 CDT

Update

Edit: This maintenance has been moved one day further in the week, from the 27th - 29th.
Posted May 23, 2025 - 16:13 CDT

Scheduled

Scheduled Maintenance Notification
We will be performing scheduled maintenance on all Calix GigaSpire routers during the overnight hours of June 3-5, 2025, between 12:00 a.m. and 5:00 a.m. each night. During this time, subscribers may experience a brief internet outage lasting approximately 5 to 10 minutes.
This maintenance is part of our ongoing commitment to providing fast, reliable service. We value your business and thank you for your understanding during this brief maintenance.
Posted May 23, 2025 - 13:21 CDT
This scheduled maintenance affects: Network Services (Network Infrastructure).